ZED camera not working with RTAB-Map

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

ZED camera not working with RTAB-Map

jess-25
Hello,

I have been trying to work with the ZED camera and RTAB-Map but I keep getting this error when using these commands:
$ export ROS_NAMESPACE=camera
$ roslaunch zed_wrapper zed_camera.launch
the error I get s5.png

Any idea about why this happens ?

Thank you
Reply | Threaded
Open this post in threaded view
|

Re: ZED camera not working with RTAB-Map

jess-25
Also, I get the ZED camera to work with RTAB-Map only by using the command:
$ roslaunch rtabmap_ros rtabmap.launch rtabmap_args:="--delete_db_on_start" depth_topic:=/camera/depth/depth_registered frame_id:=zed_camera_center approx_sync:=false

However, the point cloud I get is distorted as you can see here:
sc2.png
Do you know how can I fix these issues ?

 Thank you
Reply | Threaded
Open this post in threaded view
|

Re: ZED camera not working with RTAB-Map

matlabbe
Administrator
In the first email, you were launching rtabmap standalone, not rtabmap_ros.

The second approach you used is from this tutorial. The depth distortion is indeed what you get with the ZED on texture-less surfaces. You may tune the parameters in the camera launch file, like quality and confidence: https://docs.stereolabs.com/overview/depth-sensing/advanced-settings/

If you want to use OpenCV stereo BM approach to compute disparity instead, use zed like a stereo camera. See this tutorial instead. Note that I just fixed the following error in this commit to make it works again with the zed:
Input type must be image=mono8,mono16,rgb8,bgr8 (mono8 recommended), received types are bgra8 (left) and bgra8 (right)

cheers,
Mathieu