RTABMap base_controller/odom no new message

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view

RTABMap base_controller/odom no new message


I have been following the steps of running RTABMap on a robot explained here. The configuration I am using is a "custom" robot with encoders sending messages to an arduino, which then forwards it to my NUC.

The commands I an running on ubuntu are first
>>rosrun rosserial_python serial_node.py /dev/ttyACM0
>>roslaunch openni_launch openni.launch depth_registration:=true device_id:=#2
>>roslaunch rtabmap_ros kinectdepth.launch args:="delete_db_on_start"

the kinectdepth.launch file is the code given on topic 2.2 Kinect + Odometry + Fake 2D laser from Kinect in the steps.

The problem is that when running it gives the warning
[ WARN] [1538987123.100325623]: /rtabmap/rtabmap: Did not receive data since 5 seconds! Make sure the input topics are published ("$ rostopic hz my_topic") and the timestamps in their header are set. If topics are coming from different computers, make sure the clocks of the computers are synchronized ("ntpdate"). If topics are not published at the same rate, you could increase "queue_size" parameter (current=10).
/rtabmap/rtabmap subscribed to (approx sync):

I tried rostopic hz <my topic> on all the listed ones and everyone gave a result except /base_controller/odom which said
no new messages

The major code for the adruino is from here. I did make a few changes according to my robot. I have attached the .ino file as well.


I tried setting different baudrates but to no avail.

Kindly help me solve this issue. Thanks.

Reply | Threaded
Open this post in threaded view

Re: RTABMap base_controller/odom no new message


Your odometry topic is called "ard_odom", change rtabmap config to use "/ard_odom" instead of "/base_controller/odom".